2012年1月6日金曜日

「spark.primitives:BitmapImageに代入可能である必要があります」が出たら・・・

FB4で作っていたスキンをFB4.6でコンパイルし直そうとするとこんなエラーが。

スキンパート型 "spark.components:Image" は "spark.primitives:BitmapImage" に代入可能である必要があります。

まったく意味がわからん(^^);

HostComponentのところにエラーマークが出るけど、エラーの原因はまったく違うところだった。

まず、mx:Imageを使っていた場所をs:Imageに変更してみたけどまだエラー。

そこで、さらにs:Imageをs:BitmapImageに変更するとエラーはなくなった。